Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
migration [Le 17/01/2019, 10:51]
piti modernisation (version plus récentes)
migration [Le 10/06/2019, 15:34]
dpled Actualisation des numéros de versions (partie 1.1 et 1.2)
Ligne 1: Ligne 1:
 {{tag>​portail installation}} {{tag>​portail installation}}
 ----- -----
 +======Mise à niveau (migration)======
 +
 +Ce document d'​introduction répond aux questions les plus courantes concernant la mise à niveau d'​Ubuntu et ses variantes vers une version ultérieure. Nous vous rappelons qu'une mise à niveau n'est pas à prendre à la légère, d'où la raison pour laquelle nous vous invitons fortement à prendre connaissance du présent document et du guide de [[:​migration|mise à niveau de la version]] qui vous concerne avant de procéder.
 +
  
-ajouter les dépots à sources.list pour la version que l'on upgrader et faire sudo apt list --upgradable puis pour des paquets spécifiques ​ sudo apt list --upgradable ​ | grep "nom du paquet pour installer sudo aptitude install "nom du paquet 
 ===== Mise à niveau et mise à jour : quelle différence ? ===== ===== Mise à niveau et mise à jour : quelle différence ? =====
  
-Le terme **« mise à niveau »**, ou //« migration »//, est un processus qui permet de passer d'une ancienne [[:​versions|version]] d'​Ubuntu (ou d'une de ses [[:​variantes]]) à une version plus récente de la distribution. Un exemple de mise à niveau est le passage d'une installation courante d'​Ubuntu ​12.10 à une version ultérieure,​ Ubuntu ​13.04. Utiliser la toute dernière version d'​Ubuntu peut être intéressant car celle-ci gère de plus en plus de nouveaux matériels et périphériques,​ et est toujours plus optimisée dans l'​utilisation des ressources de votre ordinateur //(cf. [[#​la_mise_a_niveau_est-elle_obligatoire_est-elle_utile_pour_moi|"​La mise à niveau est-elle utile pour moi ?"​]])//​.+Le terme **« mise à niveau »**, ou //« migration »//, est un processus qui permet de passer d'une ancienne [[:​versions|version]] d'​Ubuntu (ou d'une de ses [[:​variantes]]) à une version plus récente de la distribution. Un exemple de mise à niveau est le passage d'une installation courante d'​Ubuntu ​17.10 à une version ultérieure,​ Ubuntu ​18.04. Utiliser la toute dernière version d'​Ubuntu peut être intéressant car celle-ci gère de plus en plus de nouveaux matériels et périphériques,​ et est toujours plus optimisée dans l'​utilisation des ressources de votre ordinateur //(cf. [[#​la_mise_a_niveau_est-elle_obligatoire_est-elle_utile_pour_moi|"​La mise à niveau est-elle utile pour moi ?"​]])//​.
  
 La **mise à niveau** est à différencier d'une simple [[:mise à jour]] : La **mise à niveau** est à différencier d'une simple [[:mise à jour]] :
Ligne 11: Ligne 14:
   * la mise à niveau (migration) implique //un passage de votre version d'​Ubuntu à une version ultérieure//​. Lors d'une mise à niveau, le migrateur fait passer vos logiciels en une version plus récente, de même qu'​installe,​ remplace ou désinstalle certains logiciels nouveaux ou, au contraire, obsolètes. //La mise à niveau **a un impact en profondeur** sur votre système//, et doit être faite en connaissance de cause.   * la mise à niveau (migration) implique //un passage de votre version d'​Ubuntu à une version ultérieure//​. Lors d'une mise à niveau, le migrateur fait passer vos logiciels en une version plus récente, de même qu'​installe,​ remplace ou désinstalle certains logiciels nouveaux ou, au contraire, obsolètes. //La mise à niveau **a un impact en profondeur** sur votre système//, et doit être faite en connaissance de cause.
  
-==== Ubuntu ​17.10 vers Ubuntu 18.04 : est-ce une mise à jour ou mise à niveau ? ====+==== Ubuntu ​18.04 LTS vers Ubuntu 18.10 : est-ce une mise à jour ou mise à niveau ? ====
  
 Il s'agit d'une **mise à niveau**. Vous passez votre système Ubuntu d'une version quelconque vers une version plus récente. Le passage à une nouvelle version implique des changements majeurs, en profondeur, tels des nouveaux logiciels, des nouveaux services et des nouveaux [[:​kernel|noyaux Linux]]. Il s'agit donc d'une mise à niveau. Il s'agit d'une **mise à niveau**. Vous passez votre système Ubuntu d'une version quelconque vers une version plus récente. Le passage à une nouvelle version implique des changements majeurs, en profondeur, tels des nouveaux logiciels, des nouveaux services et des nouveaux [[:​kernel|noyaux Linux]]. Il s'agit donc d'une mise à niveau.
  
-==== Et de Ubuntu ​14.04 LTS à Ubuntu ​14.04.LTS : mise à jour ou mise à niveau ? ====+==== Et de Ubuntu ​18.04 LTS à Ubuntu ​18.04.LTS : mise à jour ou mise à niveau ? ====
  
-Il s'agit d'une mise à jour importante marquant une étape dans les [[:​lts|versions LTS d'​Ubuntu]]. La version ​14.04.d'​Ubuntu n'​inclut pas de nouvelles applications ni de nouveaux services. Il s'agit d'une compilation des derniers correctifs de sécurité ou/et une utilisation du binôme //​[[:​kernel|noyau]]/​serveur graphique// de version supérieure. Ceci est donc une mise à jour.+Il s'agit d'​une ​**mise à jour** importante marquant une étape dans les [[:​lts|versions LTS d'​Ubuntu]]. La version ​18.04.d'​Ubuntu n'​inclut pas de nouvelles applications ni de nouveaux services. Il s'agit d'une compilation des derniers correctifs de sécurité ou/et une utilisation du binôme //​[[:​kernel|noyau]]/​serveur graphique// de version supérieure. Ceci est donc une mise à jour.
  
 Voir cette [[:​ltsenablementstack|page]] pour en savoir plus sur ce type de mise à jour. Voir cette [[:​ltsenablementstack|page]] pour en savoir plus sur ce type de mise à jour.
Ligne 28: Ligne 31:
 Si votre environnement nécessite une stabilité accrue et homogène (p. ex. : les milieux d'​entreprise),​ utiliser des [[:​lts|versions soutenues à long terme (LTS)]] est recommandé,​ car elles sont soutenues et bénéficient de mises à jour de sécurité pour une période prolongée pendant 5 ans pour les versions desktop et serveur depuis la version 12.04 LTS. Effectuez des mises à niveau de version LTS à version LTS+1 lorsque votre version actuelle arrive en fin de vie. Si votre environnement nécessite une stabilité accrue et homogène (p. ex. : les milieux d'​entreprise),​ utiliser des [[:​lts|versions soutenues à long terme (LTS)]] est recommandé,​ car elles sont soutenues et bénéficient de mises à jour de sécurité pour une période prolongée pendant 5 ans pour les versions desktop et serveur depuis la version 12.04 LTS. Effectuez des mises à niveau de version LTS à version LTS+1 lorsque votre version actuelle arrive en fin de vie.
  
-<note help>​**//​« Ma version d'​Ubuntu arrive prochainement ou est arrivée en fin de vie. Suis-je obligé de procéder à une mise à niveau ? »//** \\ Dans l'​absolu,​ vous n'​êtes pas obligé de procéder à une mise à niveau, car Ubuntu ne contient aucun mécanisme bloquant l'​utilisation d'une version non-soutenue. Toutefois, utiliser une version non-soutenue n'est pas recommandé car :+<note help>​**//​« Ma version d'​Ubuntu arrive prochainement ou est arrivée en fin de vie. Suis-je obligé de procéder à une mise à niveau ? »//** \\ Dans l'​absolu,​ vous n'​êtes pas obligé de procéder à une mise à niveau, car Ubuntu ne contient aucun mécanisme bloquant l'​utilisation d'une version non-soutenue. Toutefois, utiliser une version non soutenue n'est pas recommandé car :
   * vous n'​obtiendrez plus d '​assistance((La documentation ubuntu-fr ne contient pas d'​informations concernant les versions obsolètes, et peu d'​utilisateurs du forum sauront vous guider car n'​utilisant pas la même version que vous.)) ;   * vous n'​obtiendrez plus d '​assistance((La documentation ubuntu-fr ne contient pas d'​informations concernant les versions obsolètes, et peu d'​utilisateurs du forum sauront vous guider car n'​utilisant pas la même version que vous.)) ;
   * et les éventuelles failles de sécurités affectant vos logiciels ne seront plus corrigées.   * et les éventuelles failles de sécurités affectant vos logiciels ne seront plus corrigées.
Ligne 35: Ligne 38:
  
 ===== À partir de quelle version puis-je effectuer une mise à niveau vers la version la plus récente d'​Ubuntu ? ===== ===== À partir de quelle version puis-je effectuer une mise à niveau vers la version la plus récente d'​Ubuntu ? =====
-  * Pour mettre à niveau vers une version intermédiaire d'​Ubuntu,​ vous devez effectuer une mise à niveau à partir de la version stable directement précédente. Par exemple, une mise à niveau vers Ubuntu ​17.04 ne peut être effectuée qu'à partir de la précédente version stable ​16.10 ; +  * Pour mettre à niveau vers une version intermédiaire d'​Ubuntu,​ vous devez effectuer une mise à niveau à partir de la version stable directement précédente. Par exemple, une mise à niveau vers Ubuntu ​19.04 ne peut être effectuée qu'à partir de la précédente version stable ​18.10 ; 
-  * Pour mettre à niveau vers une version LTS d'​Ubuntu,​ vous devez effectuer une mise à niveau à partir de la version stable directement précédente ou de la version LTS directement précédente. Par exemple, une mise à niveau vers Ubuntu ​16.04 LTS ne peut être effectuée qu'à partir de la précédente version (15.10) ou de la précédente version LTS (14.04).+  * Pour mettre à niveau vers une version LTS d'​Ubuntu,​ vous devez effectuer une mise à niveau à partir de la version stable directement précédente ou de la version LTS directement précédente. Par exemple, une mise à niveau vers Ubuntu ​18.04 LTS ne peut être effectuée qu'à partir de la précédente version (17.10) ou de la précédente version LTS (16.04).
  
 Pour connaître la version actuelle de votre système, consultez [[:​versions#​connaitre_sa_version|la rubrique d'​aide]]. Pour connaître la version actuelle de votre système, consultez [[:​versions#​connaitre_sa_version|la rubrique d'​aide]].
Ligne 86: Ligne 89:
   sudo apt-get -f install   sudo apt-get -f install
  
 +FIXME la commande qui suit semble ne plus prendre en compte ​ le -a à vérifier.
 Si votre mise à niveau ne s'est pas terminée ou qu'un souci majeur est intervenu, vous pouvez tenter la commande : Si votre mise à niveau ne s'est pas terminée ou qu'un souci majeur est intervenu, vous pouvez tenter la commande :
 <​code>​sudo dpkg-reconfigure -phigh -a</​code>​ <​code>​sudo dpkg-reconfigure -phigh -a</​code>​
Ligne 93: Ligne 97:
 Notez qu'​elle peut durer un certain temps, parfois une heure. Notez qu'​elle peut durer un certain temps, parfois une heure.
  
-[[http://​www.clapico.com/​2009/​12/​02/​reinstallez-ubuntu/​|Source]] 
-<​note>​L’option -a n’existe plus pour dpkg-reconfigure sous Ubuntu 15.04. Cette dernière commande n’est donc plus possible.</​note>​ 
 ===== Guides spécifiques de mise à niveau ===== ===== Guides spécifiques de mise à niveau =====
- 
- 
- 
-==== Versions soutenues ==== 
- 
-=== vers 16.04 === 
- 
-Possible depuis 15.10 ou depuis 14.04. ​ 
- 
-=== vers 14.04 === 
- 
-Possible depuis 13.10 ou depuis 12.04. ​ 
- 
-. 
- 
- 
- 
- 
- 
  
 ==== Versions non soutenues (obsolètes,​ fin de vie) ==== ==== Versions non soutenues (obsolètes,​ fin de vie) ====
 La migration vers une [[:​old-releases|version obsolète d'​Ubuntu]] n'est pas possible. [[:​tutoriel:​sauvegarder_home|Sauvegarder vos données]] et installer une [[:​versions|version]] encore soutenue est la seule procédure recommandée.\\ La migration vers une [[:​old-releases|version obsolète d'​Ubuntu]] n'est pas possible. [[:​tutoriel:​sauvegarder_home|Sauvegarder vos données]] et installer une [[:​versions|version]] encore soutenue est la seule procédure recommandée.\\
-Les [[:​dépôts]] des vieilles versions n'​étant plus supportées (comme ​14.10, 15.04 et 15.10) ont été déplacées vers un serveur d'​archive. Aussi, il faudra modifier la liste des dépôts: Voir cette [[:​old-releases|page]].+Les [[:​dépôts]] des vieilles versions n'​étant plus supportées (comme ​16.10, 17.04 et 17.10) ont été déplacées vers un serveur d'​archive. Aussi, il faudra modifier la liste des dépôts: Voir cette [[:​old-releases|page]].
  
 ===== Migration en ligne de commande (plutôt destinée aux serveurs ou aux utilisateurs avancés)===== ===== Migration en ligne de commande (plutôt destinée aux serveurs ou aux utilisateurs avancés)=====
  • migration.txt
  • Dernière modification: Le 10/06/2019, 15:34
  • par dpled