Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
Dernière révision Les deux révisions suivantes
appimage [Le 21/05/2019, 18:12]
92.157.246.82 [Appimage] le mot "impacter" n'a pas de sens ici (se reporter au site de l'Académie Française : http://www.academie-francaise.fr/impacter)
appimage [Le 18/05/2020, 15:22]
eagle08 [Absence de pré-requis]
Ligne 1: Ligne 1:
-{{tag>Trusty Xenial ​application format paquet}}+{{tag>Bionic ​application format paquet}}
  
 ---- ----
Ligne 13: Ligne 13:
 ==== Absence de pré-requis ==== ==== Absence de pré-requis ====
  
-La grande force d'​**Appimage** ​est que ce format ne nécessite **__aucun__ pré-requis** :+La grande force d'​**Appimage** ​réside dans le fait que ce format ne nécessite **__aucun__ pré-requis** :
   * aucun droit d'​administration   * aucun droit d'​administration
   * aucun paquet ni aucune librairie à installer préalablement   * aucun paquet ni aucune librairie à installer préalablement
  
-Il faut cependant vous fournir les fichiers, ce qui nécessite en toute logique d'​avoir une connexion internet.+Il faut cependant ​que vous ayez accès aux fichiers, ce qui nécessite en toute logique d'​avoir une connexion internet.
 ==== Mises à jour ==== ==== Mises à jour ====
  
Ligne 28: Ligne 28:
 Les logiciels fournis dans ce format ne sont pas réellement installés sur le système, et ne sont donc pas présents dans les menus, il faut manuellement [[:​raccourci-lanceur|créer un lanceur]] vers le fichier appimage concerné. Les logiciels fournis dans ce format ne sont pas réellement installés sur le système, et ne sont donc pas présents dans les menus, il faut manuellement [[:​raccourci-lanceur|créer un lanceur]] vers le fichier appimage concerné.
  
-<​note>​Certains logiciels (comme //Etcher//, //Motrix// ou //​[[:​Molotov]]//​) proposent, au moment de la première utilisation,​ de créer un lanceur automatiquement,​ ça reste cependant une pratique peu répandue.</​note>​+<​note>​Certains logiciels (comme //Etcher//, //Motrix// ou //​[[:​Molotov]]//​) proposent, au moment de la première utilisation,​ de créer un lanceur automatiquement,​ ça reste cependant une pratique peu répandue.
  
 +Nous vous conseillons de créer un dossier Appimage dans Documents et y sauvegarder également les icônes de vos applications,​ afin de faciliter la création des lanceurs.
 +</​note>​
 +
 +==== Paquets téléchargés hors-dépôts ====
 +**Synaptic** gère des paquets au format ''​.deb''​ ​**provenant de dépôts APT uniquement**. ​ \\ Il ne permet ​pas — dans sa configuration actuelle — l'​​installation d'un paquet téléchargé manuellement depuis un site Internet ou généré par vous-même. \\ ​Si vous cherchez à effectuer ces manipulations,​ lisez les sections suivantes ou utilisez plutôt [[:gdebi]].
 +
 +=== Paquets téléchargés manuellement ===
 +
 +== Les paquets pré-compilés au format *.deb ==
 +
 +Afin de gérer les paquets pré-compilés .deb que vous téléchargez manuellement ( par exemple **depuis les sites de confiance** **Sourceforge** ou **Github**) vous devez configurer l'​application qui les installera par défaut. il s'agit de la Logithèque Ubuntu. ​
 +
 +
 +== Les paquets pré-compilés au format *.deb à l'aide de l'​application Checkinstall ==
 +
 +Contrairement à l'​idée préconçue selon laquelle Synaptic serait incapable de gérer les sources compilés manuellement,​ **ceci est tout à fait possible à l'aide de l'​application checkinstall**. \\
 +Cet utilitaire en ligne de commandes simplissime à utiliser compile les sources en C++ puis génère un paquet pré-compilé *.deb. \\
 +Cette procédure permet d'​intégrer ensuite le paquet généré manuellement à la bibliothèque de Synaptic.
 +
 +Pour de plus amples informations sur l'​application Checkinstall,​ reportez vous au chapitre [[checkinstall|Checkinstall :​ Créer facilement un paquet debian (*.deb) à partir des sources]] de la documentation.
 +
 +
 +==== Formats de distribution alternatifs ====
 +Synaptic ne sait pas gérer les logiciels précompilés au format [[:​Flatpak]] ni [[:​snap|Snap]] ni [[:​Appimage]] encore moins les applications hébergées sur [[wp>​https://​fr.wikipedia.org/​wiki/​GitHub|Github]]. \\ Si votre logithèque ne gère pas nativement ces formats, des procédures spécifiques à chaque format vous seront nécessaires.
 +
 +=== Les nouveaux modules d'​intégration à Ubuntu ===
 +Depuis Ubuntu 17.10, rétroportés sous 16.04, il existe des applications d'​intégration des paquets **Flatpak**,​ **Snap**, **Appimage** et des application hébergées sur le Github. \\ Les procédures d’intégration diffèrent selon le paquet précompilé considéré.
 +  * Intégration de **Snap** dans la Logithèque Ubuntu : \\ le service snapd est désormais intégré aux distribution récentes d'​Ubuntu. Pour gérer les Snaps depuis la logithèque,​ il vous suffit de vous rendre sur [[https://​snapcraft.io/​snap-store|la page officielle du Snapstore]] et de cliquer sur le bouton **[ install ]** ( Ubuntu 16.04 et suivantes ) <code bash>​sudo snap install snap-store ​
 +sudo apt-get update </​code>​
 +  * Intégration du dépôt officiel **Flathub** au sein de Synaptic : <code bash>
 +sudo flatpak remote-add --if-not-exists flathub https://​flathub.org/​repo/​flathub.flatpakrepo </​code>​
 +  * Intégration de **Flatpak** dans la logithèque Ubuntu : ( Ubuntu 16.04 et suivantes ) <code bash>​sudo apt install gnome-software-plugin-flatpak
 +sudo apt-get update </​code>​ \\ pour les autres gestionnaires de bureaux, se référer à la page « [[https://​www.numetopia.fr/​installation-et-utilisation-de-flatpak-sous-ubuntu/​|Installation et utilisation de Flatpak sur Ubuntu]] » \\ — site : Numétopia.fr ; auteur : le tux masqué ; date : 21 août 2019 ; mise à jour : 6 novembre 2019. \\ 
 +    * Pour lister vos paquets Flatpak, entrez dans un [[terminal|Terminal]] : <code bash>
 +flatpak list </​code>​
 +    * Pour mettre à jour tous vos paquets Flatpak, entrez dans un [[terminal|Terminal]] : <code bash>
 +flatpak update </​code>​
 +  * Intégration de **Appimage** au sein des différentes interfaces graphiques d'​Ubuntu : 
 +    * se référer à [[https://​www.linuxuprising.com/​2018/​04/​easily-run-and-integrate-appimage-files.html|Easily Run And Integrate AppImage Files With AppImageLauncher]] ​ \\ — site : Linuxuprising.com ; auteur : logix ; date : 17 juillet 2018.
 +    * télécharger le paquet précompilé *.deb sur la page Github dédiée « [[https://​github.com/​TheAssassin/​AppImageLauncher/​releases|Appimage Launcher release builds]] ».
 +  * Intégration de **Github Desktop** au sein des différentes interfaces graphiques d'​Ubuntu : <code bash>​sudo snap install github-desktop --edge </​code>​ \\ Le paquet github-desktop permet de gérer son dépôt Github graphiquement dans une application intégrée au gestionnaire d'​applications Ubuntu
 +
 +<​note>​**Le projet précédent nommé __Appimaged__ est désormais déprécié**. \\
 +Ceci ne vous empêche nullement de l'​utiliser en complément de Appimage Launcher. Pour l'​installer **après avoir installé Appimage Launcher** :
 +<code bash>​wget "​https://​github.com/​AppImage/​appimaged/​releases/​download/​continuous/​appimaged-x86_64.AppImage"</​code>​
 +rendez vous dans votre dossier personnel
 +<code bash> sudo chmod a+x appimaged-x86_64.AppImage</​code>​
 +<code bash>​sudo ./​appimaged-x86_64.AppImage --install</​code>​
 +
 +=============================================== ~oOo~ =====================================================================
 +
 +__''​IMPORTANT''​__ : ''​Mise à jour de cette note''​ \\
 +**Appimaged et AppimageLauncher sont fortement dépréciés et leur installation déconseillée depuis l'​arrivée de [[bauh|Bauh]]**. \\ Ces derniers produisant des bogues. **Ils sont en outre incompatibles avec Bauh**. \\
 +Si vous avez installé AppimageLaucher manuellement et que vous désirez suivre nos recommandations et souhaitez installer Bauh afin de bénéficier d'un gestionnaire stable pour les fichiers Snaps, Flatpak et Appimage, entrer cette commande dans un terminal :
 +<code bash>
 +sudo find / -type f -name "​[Aa]pp[Ii]mage[Ll]auncher"​ -exec rm -f '​{}'​ \;
 +sudo find / -type f -name "​[Aa]ppimaged"​ -exec rm -f '​{}'​ \; 
 +</​code>​
 +
 +En effet, vous devez désinstaller toute "​trace"​ de ces deux logiciels avant l'​utilisation du module Appimage de Bauh. \\
 +Rendez-vous sur [[bauh|la page de Bauh]].
 +</​note>​
 ==== Taille des fichiers ==== ==== Taille des fichiers ====
  
Ligne 54: Ligne 116:
   * En ligne de commande (pour une application fictive nommée truc) : \\ <​code>​chmod a+x truc.appImage</​code>​   * En ligne de commande (pour une application fictive nommée truc) : \\ <​code>​chmod a+x truc.appImage</​code>​
  
-<note help>Le format appimage est en fait une archive, qui contient le logiciel et toutes les librairies ​dont il dépend, si vous oubliez de le rendre exécutable,​ l'​archive se montera comme un simple disque amovible, explorable avec un gestionnaire de fichiers !</​note>​+<note help>Le format appimage est en fait une archive, qui contient le logiciel et toutes les bibliothèques ​dont il dépend, si vous oubliez de le rendre exécutable,​ l'​archive se montera comme un simple disque amovible, explorable avec un gestionnaire de fichiers !</​note>​
  
 ===== Utiliser un appimage ===== ===== Utiliser un appimage =====
  • appimage.txt
  • Dernière modification: Le 18/05/2020, 15:54
  • par eagle08